Windows DatabaseebooksStatistical Information

LLE10226 : Howto install the qt development kit on debian 5.0 Lenny (qt creator)

Symptom:

You want to install QtCreator on debian or kubuntu

Cause:

none

Solution:

This is a wonderfull development environment for windows, Linux and more

Go to the trolltech (now Nokia) website and make a download of the development kit.

In my case it was the file "qt-sdk-linux-x86_64-opensource-2009.03.1.bin". Save it in your homedirectory as a normal user. After the download you need to make it executable with

chmod +x qt-sdk-linux-x86_64-opensource-2009.03.1.bin

Now you can run the binary.

./qt-sdk-linux-x86_64-opensource-2009.03.1.bin

I installed it in my homedirectory under qtsdk-2009.03 which is the default.

When you start qtcreator (located in the bin directory of the qtsdk installation) you can start your first program.

I needed to install some extra libraries to get the first program working. Because of the cannot find -lSM -gObject -libext error messages. After installing the following libraries I could compile the first programs.

apt-get install libxft-dev libfreetype6-dev
apt-get install libgee-dev
apt-get install libslang2-dev
apt-get install libsm-dev
apt-get install libextractor-dev

Have fun with Qt development.

Disclaimer:

The information provided in this document is intended for your information only. Lubby makes no claims to the validity of this information. Use of this information is at own risk!
Copyright © 2004-2011 Lubby (V3.0.10 Aug 2011)
Sponsored by Keskon.
Statistical information by Google Analytics