LKBEN11180: Howto show some detailed information about an installed debian package.


This article has not been checked!

LKB | Created: 02/04/2020 | Version: 0 | Language: EN | Rating: 0 | Outdated: False | Marked for deletion: False

Author: Wim Peeters - Keskon GmbH & Co. KG


Symptom

You have debian, kubuntu, ubuntu or knoppix and want to have information about a package.

Cause

none

Solution


There are more ways to find information about a package and perhaps the internet is the most suitable for most of us but the following command delivers some detailed information about an installed package. e.g.

apt-cache show postgresql-8.3

The output from a german system:

ls02:/etc# apt-cache show postgresql-8.3
Package: postgresql-8.3
Priority: optional
Section: misc
Installed-Size: 13736
Maintainer: Martin Pitt <mpitt@debian.org>
Architecture: i386
Version: 8.3.9-0lenny1
Depends: libc6 (>= 2.7-1), libcomerr2 (>= 1.01), libkrb53 (>= 1.6.dfsg.2), libldap-2.4-2 (>= 2.4.7), libpam0g (>= 0.99.7.1), libpq5 (>= 8.3~beta1), libssl0.9.8 (>= 0.9.8f-5), libxml2 (>= 2.6.27), postgresql-client-8.3, postgresql-common (>= 79), tzdata, ssl-cert, locales
Suggests: oidentd | ident-server
Conflicts: postgresql (<< 7.5)
Filename: pool/main/p/postgresql-8.3/postgresql-8.3_8.3.9-0lenny1_i386.deb
Size: 5237200
MD5sum: bea3a11c86370a7cb86471c70e387f1f
SHA1: e19d9b15fddff5c008a99bc5b402fc5b5a54b269
SHA256: 1f9304989355070717259fcc488a50b9f872e951051ca9d5d089baa2614d21fd
Description-de: Objektrelationale SQL-Datenbank, Version 8.3, Server
 PostgreSQL ist ein voll funktionsfähiges, objektrelationales
 Datenbanksystem. Es unterstützt einen Großteil des SQL-Standards und ist
 so gestaltet, dass es vom Benutzer in vielfältiger Weise erweitert werden
 kann. Einige der Funktionen sind: ACID-Transaktionen, Fremdschlüssel,
 Sichten (Views), Sequenzen, Unterabfragen, Trigger, benutzerdefinierte
 Datentypen und Funktionen, outer joins, multiversion concurrency control.
 Weiterhin sind grafische Bedienoberflächen und Anbindungen an viele
 Programmiersprachen verfügbar.
 .
 Dieses Paket stellt den Datenbank-Server für PostgreSQL 8.3 zur Verfügung.
 Server für andere Major-Release-Versionen können gleichzeitig installiert
 und mit Hilfe des Pakets postgresql-common koordiniert werden. Sie brauchen
  ein Paket, das ident-server zur Verfügung stellt, wenn Sie entfernte
 Verbindungen mit identd authentifizieren möchten.
Tag: devel::lang:sql, interface::daemon, network::server, network::service, protocol::db:psql, role::program, works-with::db

 

 

About the Author

Wim Peeters is electronics engineer with an additional master in IT and over 30 years of experience including time spent in support, development, consulting, training and database administration. Wim has worked with SQL Server since version 6.5. He has developed in C/C++, Java and C# on Windows and Linux in different European countries and different European languages. He writes knowledge base articles to solve IT problems and publishes them on the Lubby Knowledge Platform where he is one of the most important contributors and the main developer.

Disclaimer:

The information provided in this document is intended for your information only. Lubby makes no claims to the validity of this information. Use of this information is at own risk!