LKBEN10933: Windbg debugging symbols cannot be loaded because of a proxy


This article has not been checked!

LKB | Created: 02/04/2020 | Version: 0 | Language: EN | Rating: 0 | Outdated: False | Marked for deletion: False

Author: Wim Peeters - Keskon GmbH & Co. KG


Symptom

You need debugging symbols but they cannot be loaded because of a configured proxy

Cause

none

Solution

First of all you can make the loading of the symbols noisy with the following command:

!sym noisy

Now WinDbg will show you how it is resolving the symbols and will show you errors as well.

Now you should check your symbol path. e.g.

srv*C:\Symbols\MsSymbols*http://msdl.microsoft.com/download/symbols;

Please make shure it is right. If your system cannot download any symbols try to set the variable _NT_SYMBOL_PROXY=yourproxy:yourport. e.g.

_NT_SYMBOL_PROXY=proxysrv:81

Try to reload with the .reload command and test with lm. (list loaded modules)

About the Author

Wim Peeters is electronics engineer with an additional master in IT and over 30 years of experience including time spent in support, development, consulting, training and database administration. Wim has worked with SQL Server since version 6.5. He has developed in C/C++, Java and C# on Windows and Linux in different European countries and different European languages. He writes knowledge base articles to solve IT problems and publishes them on the Lubby Knowledge Platform where he is one of the most important contributors and the main developer.

Disclaimer:

The information provided in this document is intended for your information only. Lubby makes no claims to the validity of this information. Use of this information is at own risk!